www.ClickEXE.de Click.EXE - In 5 Minuten zum eigenen Programm!
cX5 Zahnräder Jetzt neu: click.EXE 5.0 - Hier klicken für weitere Informationen cX5 Zahnräder
Start Einloggen Einloggen Die Mitglieder Das Foren-Team Suchfunktion
30907 Posts & 5506 Themen in 34 Foren
Benutzername/Passwort:
  Login speichern
Forenübersicht » Click.EXE 4.0 » cX4: Probleme mit PlugIns » Element+ auf Zeichenfläche bringt Fehler

vorheriges Thema   nächstes Thema
3 Posts in diesem Thema (offen)
Seiten (1): (1)
Autor
Beitrag
tivoli ist offline tivoli  
Element+ auf Zeichenfläche bringt Fehler
12 Beiträge - Click.EXE Anfänger
Hallo zusammen,

mit dem Element+ Plugin tritt in Verbindung mit einer Zeichenfläche ein fehlerhaftes Verhalten auf.

Ich habe ein Fenster mit einer Hover-Navigation auf der linken Seite. Die Hover wurden durch Bezeichner realisiert. In meinem Beispiel habe ich 5 Hover-Links angelegt. Alle Hover bis auf Hover 4 sind mit Meldungsboxen verknüpft. Hover 4 ist mit einer Element+ Liste belegt.

Bei einem Klick auf Hover 4 oeffnet sich eine Element+ Liste, die auf einer Zeichenfläche liegt. Hier tritt nun folgendes Problem auf.

Sobald Hover 4 angeklickt wird und damit die Zeichenfläche und die Element+ Liste angezeigt wird, reagieren die Hover nicht mehr und sind dann wie deaktiviert, da weder die verknüpften Befehle ausgeführt werden, noch der Hover-Effekt greift.

Wenn die Element+ Liste nicht auf einer Zeichenfläche liegt, funktioniert es jedoch wie gewünscht.

Entweder mache ich einen Fehler, oder hier ist wirklich ein Bug am Werk.

Anbei füge ich ein Beispielskript zum besseren Verständnis bei.

Verwendet wird die aktuelle Click.EXE 4 Version mit den aktuellen Plugins auf einem Windows 7 x64 Rechner.

Bin über jede Hilfe dankbar.

Vielen Dank
Tivoli


Anzeigefenster 'Fenster' (ID='1', zentriert, Kein Icon, Min. möglich)
Anzeige-Element Bezeichner: 'Hover 1' (ID='hover_1', zentriert, Zielfenster-ID: '1')
Anzeige-Element Bezeichner: 'Hover 2' (ID='hover_2', zentriert, Zielfenster-ID: '1')
Anzeige-Element Bezeichner: 'Hover 3' (ID='hover_3', zentriert, Zielfenster-ID: '1')
Anzeige-Element Bezeichner: 'Hover 4' (ID='hover_4', zentriert, Zielfenster-ID: '1')
Anzeige-Element Bezeichner: 'Hover 5' (ID='hover_5', zentriert, Zielfenster-ID: '1')
Warte endlos...

:: Anzeige(1)_Element(hover_1)_Klick
Meldung "Hover 1" (Titel: 'Meldung', Info, OK)
Zurück

:: Anzeige(1)_Element(hover_2)_Klick
Meldung "Hover 2" (Titel: 'Meldung', Info, OK)
Zurück

:: Anzeige(1)_Element(hover_3)_Klick
Meldung "Hover 3" (Titel: 'Meldung', Info, OK)
Zurück

>>...usw...<<
cX2Web-Code: (einfach anklicken, kopieren und in ... einfügen)
Hierfür benötigte Erweiterungen: Anzeige-Element+
Erstellt mit cX2Web - cX4 WebExport V3 (39 Skriptzeilen, cX Premium 4.0.5.4)

Beitrag vom 15.02.2012 - 20:03
Diesen Beitrag melden   nach weiteren Posts von tivoli suchen tivoli`s Profil ansehen tivoli eine Kurznachricht senden tivoli zu deinen Freunden hinzufügen zum Anfang der Seite
tivoli ist offline tivoli  
12 Beiträge - Click.EXE Anfänger
Hallo,

ich habe das Fehlerverhalten nun verstanden und komme zu dem Schluss, dass es tatsächlich ein Bug ist, daher ein kurzer Nachtrag von mir.

Wenn die Element+ Liste auf einer Zeichenfläche liegt, überdeckt die Höhe der Element+ Liste quasi die Einträge, hier im Beispiel die Hover-Links. Die Hover-Links sind zwar noch zu sehen, können aber nicht nicht ausgewählt werden, weil die Element+ Liste quasi unsichtbar oben drauf liegt.

Alle Hover-Links, die unter oder über der angegebenen Groesse der Element+ Liste liegen, sind problemlos anklickbar.

Ich denke, dass dieses Verhalten nicht beabsichtigt ist und würde daher mal fragen wollen, wie schnell dies zu fixen wäre?

Vielen Dank
Tivoli
Beitrag vom 15.02.2012 - 22:37
Diesen Beitrag melden   nach weiteren Posts von tivoli suchen tivoli`s Profil ansehen tivoli eine Kurznachricht senden tivoli zu deinen Freunden hinzufügen zum Anfang der Seite
tivoli ist offline tivoli  
12 Beiträge - Click.EXE Anfänger
Hallo HUP,

danke, dass du dir die Zeit hierfür nimmst.

Wenn ich den X und Y Wert wie von dir beschrieben ändere, dann sind die Hover wieder anklickbar, jedoch ist das Element dann natürlich nicht mehr an der gewünschten Stelle, was also keine Lösung ist.

Wenn die Element+ Liste nicht auf einer Zeichenfläche liegt stimmen die Koordinaten, allerdings muss ich in dem jetzigen Fall die Liste auf einer Zeichenfläche haben.

Wie ich inzwischen herausgefunden haben, betrifft es alle Arten eines Element+ Elements in Verbindung mit einer Zeichenfläche. Sobald als Zielfenster eine Zeichenfläche angegeben wird, stimmen zwar die Koordinaten, jedoch liegt es unsichtbar drüber und es wird unbedienbar.

Es wird also tatsächlich ein Fehler im Element+ Plugin sein, daher möchte ich Stefan fragen wie schnell dies zu fixen wäre?

Danke und Gruß
Tivoli
Beitrag vom 18.02.2012 - 20:57
Diesen Beitrag melden   nach weiteren Posts von tivoli suchen tivoli`s Profil ansehen tivoli eine Kurznachricht senden tivoli zu deinen Freunden hinzufügen zum Anfang der Seite
Baumstruktur - Signaturen anzeigen
Seiten (1): (1)
vorheriges Thema   nächstes Thema

Gehe zu:  
Es ist / sind gerade keine registrierte(r) Benutzer und 299 Gäste online. Neuester Benutzer: maupa
Alles gute zum Geburtstag    Wir gratulieren ganz herzlich zum Geburtstag:
Luke (55), W.Bertram (60)
aktive Themen der letzten 48 Stunden - Top-User
0
0

www.ClickEXE.de © 2022
Seite in 0.23838 sec generiert